umorpha-boxes/pkg/umorpha-www/PKGBUILD

24 lines
499 B
Bash

# Maintainer: Luke T. Shumaker <lukeshu@umorpha.io>
pkgname=umorpha-www
pkgver=2024.02.12
pkgrel=1
arch=('any')
pkgdesc='Umorpha website'
url="https://git.mothstuff.lol/lukeshu/web"
license=('AGPL')
makedepends=() #go tidy python-jsbeautifier)
source=("git+https://git.mothstuff.lol/lukeshu/web.git#commit=010ae8b8859eacb00278a58e9ce5c36647685e99")
sha256sums=('SKIP')
build() {
cd web
make
}
package() {
cd web
install -d "$pkgdir/srv/http"
cp -r static "$pkgdir/srv/http/www.umorpha.io"
}